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40. Sim Module - Common Tools 

 
 



 HSC 8 – Sim Common Tools 
November 19, 2014 
 

 

Research Center, Pori / Petri Kobylin, Lauri 
Mäenpää, Matti Hietala, Jussi-Pekka Kentala 

14022-ORC-J 2 (26) 

 

Copyright © Outotec Oyj 2014 

 

 

40.1. Drawing flowsheets and adding tables to flowsheets 
 
This chapter explains how to draw and add tables to a flowsheet. In addition to the 
instructions chapter, the user should also read unit-specific Chapters 41-47 of this manual 
before running the simulations (41- 42 Distribution Units, 43-44 Reactions Units, 45-46 
Minerals Processing Units and 47 Converter Units, which are needed if different units are 
combined in the flowsheet). 
 
The most important icons for drawing are: 
 

 
Fig. 1. Icons for drawing Units and Streams, where the first icon is Select, U = Generic Units, R = 
Reactions Units, D = Distributions Units, and the last icon is Streams. 

40.1.1. Drawing units 
 
Select the unit by left-clicking the unit icon. The cursor shows the user which icon is active. 
Move the cursor to somewhere on the flowsheet and draw a unit by a) holding down the left 
mouse button b) moving the mouse to increase the size of the unit c) releasing the button to 
stop drawing, see Fig. 2. The user can change the size of the units later. 
 

 
Fig. 2. Drawing two Reactions (Hydro) units. The Reactions unit is the active icon in this figure, see 
the mouse cursor. 

40.1.2. Drawing streams 
 
Select the stream icon with the mouse (left button). Move the cursor to somewhere on the 
flowsheet and click the mouse (left button) to start the stream. The user can add a corner to 
the stream with another click and double-click (left button) to end the drawing of the stream, 
see Fig. 3. 
 
Editing Streams 
 
How to a) make a corner on the stream b) change the angle of the stream and c) remove 
the corners of the stream d) change the input and output units of the stream e) check the 
connection of the streams. 
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a) Choose the Select icon and by holding down the shift + left mouse button, the 
user can make corners on the streams by moving the mouse. 

b) Choose the Select icon and click the stream to see the nodes (blue squares). 
Hold down the mouse button on a node and move the mouse to change the 
angle of the stream. 

c) Choose the Select icon, select the stream, then select one stream node (blue 
square), move one node on top of another node to remove a stream corner. 

d) Choose the Select icon and move the beginning or end of the stream to a new 
unit or out of the unit. HSC8 Sim will suggest a new connection to the stream 
that the user can accept (OK) or Cancel. 

e) When the flowsheet is ready, check that the streams are connected to the 
correct units. The user can check connections visually, see Fig. 4. A white circle 
or arrow means that the stream source or destination is unknown (a gray arrow 
means it is known). Blue stream means input, black stream is between two units 
and red stream means output. It is also possible to click the Tools menu to 
show the process tree. The most time-consuming task is selecting streams one 
by one and looking at the properties (process sheet) to see the source and 
destination of the stream. 

 

 
Fig. 3. Drawing streams. 

 
Fig. 4. Visualizing stream connections. 
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40.1.3. Renaming units and streams 
 
Choose the Select icon and rename units and streams by double-clicking the name or click 
the name label and edit properties (process sheet) - NameID cell, see Fig. 5. 
 

 
Fig. 5. Renaming units and streams. 

40.1.4. Inserting tables and stream tables (typically done after simulations) 
 
The user can add tables to visualize important parameters of the results. Choose the Table 
icon and draw the table in the same way as you draw the units. The user can open table 
editor by double-clicking the table, where the user can add more rows and columns. It is 
important to uncheck Size lock when adjusting the table size. It is typical to use this table to 
show a summary of the results. The user can insert header labels and add results as cell 
references in this table (copy cell reference from the unit sheets and paste cell reference in 
the table), see Fig. 6 and Fig. 7. 
 
The user can also insert stream tables by clicking the Stream Table Editor icon, which will 
open the editor where the user can add variables (by double-clicking). A visible variable list 
can be sorted by dragging the variables up and down in the list, see Fig. 8. The user can 
check which stream tables can be visible or invisible in the editor or does that later from 
View Menu...stream tables...show/hide all. 
 
 

 
Fig. 6. Table added to the flowsheet. 
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Fig. 7. Table editor, remember to uncheck Size lock when inserting rows and columns. 

 
Fig. 8. Stream tables editor for adding stream tables to the flowsheet. Add and remove variables by 
double-clicking. 
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40.1.5. Editing a flowsheet 
 
Sometimes the user wants to edit a flowsheet later and add new units. Adding a new unit 
(Unit 3) in the middle of a stream (Stream 1) connected to two units (Unit 1 and Unit 2) is 
explained here. First, draw a new unit (Unit 3) and connect Stream 1 from Unit 1 to Unit 3. 
Then add a new stream (Stream 2), which starts from Unit 3 and ends at Unit 2, see Fig. 9 - 
Fig. 11. Information in Unit 1 and Unit 2 is automatically updated so the user only needs to 
make changes in Unit 3 and Stream 3 to run the simulation. 
 

 
Fig. 9. Adding a unit to a stream between two units, starting situation. 
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Fig. 10. Adding a unit to a stream between two units, add new unit and change stream connection. 

 
Fig. 11. Adding a unit to a stream between two units, final situation. 
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40.2. Menus in the flowsheet window 
 
In this section, the Sim flowsheet menus (File, View, Select, Tools, Drawing Tools, Window 
and Help) are introduced. 
 
File menu 
 
This menu is similar to many other programs where the user can (see also Fig. 12): 
 
1. Start New Process…which opens an empty flowsheet. 
2. Open Process…which is a *.Sim8 (HSC8) or *.fls file (HSC6 or HSC7 flowsheet). 
3. Save Process…quick save process (overwrites previous version) 
4. Save Process as…save process with the file name and location given by the user 
5. Save Backup…process should be saved first before a backup can be made. It is 

recommended to save a backup from time to time during the simulation. 
6. Backups…If the user has saved backups, they can be managed (checked, restored, 

deleted) here. 
7. Recent Processes…shows the 10 most recent simulations made by the user 
8. Export Flowsheet Image…The user can export the flowsheet as an image (png, vdx, 

pdf, svg, dxf) or copy a flowsheet picture to the clipboard to use it in reports and 
presentations. 

9. Print flowsheet…prints the flowsheet 
10. Exit HSC Sim…will close the Sim program 
 

 
Fig. 12. File menu. 
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View menu 
 
In the View menu the user can: (see also Fig. 14) 
 
1. View and edit Flowsheet settings, where the user can change or restore default 

settings of the flowsheet. Exit saves the settings and leaves this editor, see Fig. 13. 
 

 
Fig. 13. Flowsheet settings. 

2. Show and hide the flowsheet Name labels, Value labels and Stream tables. 
3. Check and uncheck all Toolbars, which are explained in section 40.3. 
 

 
Fig. 14. View menu. 
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Select menu 
 
The Select menu is typically used to edit or move many properties at once. Here the user 
can: (see Fig. 15 below) 
 
1. Select all Units on the flowsheet. 
2. Select all Unit Name Labels on the flowsheet. 
3. Select all Streams on the flowsheet 
4. Select all Stream Name Labels on the flowsheet. 
5. Select all Stream Value Labels on the flowsheet. 
6. Select all Stream Tables on the flowsheet. 
7. Select all (unit and stream) Name Labels on the flowsheet. 
8. Select all (unit and stream) Value Labels on the flowsheet. 
9. Select all Other Text Labels on the flowsheet. 
10. Select All Labels on the flowsheet. 
11. Select all (not including stream tables) Tables on the flowsheet. 
12. Select all Other Drawing Objects on the flowsheet. 
13. Select All Items on the flowsheet. 
 

 
Fig. 15. Select menu. 
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Tools menu 
 
The Tools menu includes many advanced options that may be needed in flowsheet 
simulation. The user needs detailed instructions on how to use those tools. Some tools are 
explained here and others in different chapters, see the list below. The Tools menu 
includes: (see Fig. 17) 
 
1. Process information 
 

 
Fig. 16. The user can add Process Information to this sheet. 

2. LCA Evaluation (see Chapter 49) 
3. Mass Balancing (see Chapters 51 and 52) 
4. Reports (see section 40.2.1) 
5. Select Unit Models (see section 40.2.2) 
6. Scenario Editor (see section 40.2.3) 
7. Show the process tree (see section 40.2.4) 
8. Errors in flowsheet (shows possible errors in the flowsheet) 
 

 
Fig. 17. Tools menu options. 
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40.2.1. Reports 
 
A summary of flowsheet results can be saved and printed here. There are two pages in this 
report sheet: one for units and one for streams. This report uses Hydro_example3.Sim8. 
 

 
Fig. 18. Stream balance sheet of the report file. 

 
Fig. 19. Unit balance sheet of the report file. 
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40.2.2. Select Unit Models 
 
The user can choose different models for the units. The Select Unit Models window can be 
opened from the Tools menu or by right-clicking if the cursor is on top of one of the units, 
see Fig. 20. On the left side of the window is the list of units on the flowsheet. In the middle 
part the user can select a unit model from the Reactions, Distribution, Particle and Others 
sheet (and in the HSC8 update also ‘Import own unit models’). Double-click the unit to 
select it and then click OK. Most of the units are dll type but there are still some Excel 
Wizards available for the Reactions units. If Excel Wizards are chosen, the user needs to 
check the stream names. Information about the units can be found on the right side of the 
selector window. Empty Reactions or Distributions units are the same as R and D unit Icons 
on the main flowsheet DrawBar, see Fig. 1. 
 
In the HSC8 update (November 2014), there will be instructions on how users can make 
their own dll units (Chapter 50). User-made units can be imported using the import sheet. 
 

 
Fig. 20. Select Unit Models window. 
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40.2.3. Scenario Editor 
 
The Scenario Editor lets you run your process model with different operating parameters 
and see how they affect process variables. The calculated results can then be collected in 
the charts. 
 
To use the Scenario Editor, first select the processing parameter that you want to regulate 
and copy its cell reference from the appropriate cell. Next, open the Scenario Editor and 
paste the cell reference in the first SET/GET column (Fig. 21). Then you can add a name 
and measurement unit for this variable, but most importantly you should specify whether the 
variable will be a regulated (SET) or a calculated variable (GET) (Fig. 22). 
 

 
Fig. 21. Add variables to the Scenario Editor by pasting the cell reference of the variable cell.  
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Fig. 22. Specify the SET/GET value for the variable. 

After adding enough variables, specify the parameter values for the SET columns, add 
some charts, and finally run the scenario (Fig. 23). 
 

 
Fig. 23. After specifying the variables, enter the SET variable values, add charts, and run the 
scenario. 
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The calculation results will then be presented in the spreadsheet as well as in the charts 
(Fig. 24). 
 

 
Fig. 24. Results of the scenario. 
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40.2.4. Show Process Tree 
 
With this option the user can see the flowsheet information and connections of the process 
streams with colors. If a stream is not connected to the unit, it will not be visible in this 
process tree. 
 

 
Fig. 25. Show process tree. 
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Drawing Tools menu 
 
The user can edit the flowsheet using Drawing Tools by aligning, sizing, rotating, grouping, 
and drawing, see Fig. 26. 
 
One handy way of editing the flowsheet is Edit Pages and Layers where you can set layers 
and properties which are visible or invisible on your flowsheet, see Fig. 27. 
 
The user can find more details about Drawing Tools in section 40.3. 
 

 
Fig. 26. Drawing tools. 

 
Fig. 27. Edit Pages and Layers window. 
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Window and Help menus 
 
The Window menu shows the user the name of the flowsheet, see Fig. 28. 
 
The Help menu shows a list of software developers and technical advisors and a link to the 
Sim manual, see Fig. 29 and Fig. 30. 
 

 
Fig. 28. Window menu. 

 
Fig. 29. Help menu. 

 
Fig. 30. About HSC8 Sim. 
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40.3. Toolbars 
 
In the View Toolbars menu, the user can check and uncheck toolbars. It is also possible to 
reset docking bar positions back to their default places. Toolbars are divided into two lists: 
Docking bars and Drawing toolbars, see Fig. 31. 
 

 
Fig. 31. List of toolbars. 

40.3.1. Drawing toolbars 
 
The Drawing toolbars are listed and guidance on their usage briefly described in Fig. 32 - 
Fig. 42. Many drawing options can be later edited from docking toolbar Properties after 
they have been drawn (section 40.3.2). 
 

 
Fig. 32. Units and streams (DrawBar). Select or Draw Units or Draw Streams (see also section 
40.1). 



 HSC 8 – Sim Common Tools 
November 19, 2014 
 

 

Research Center, Pori / Petri Kobylin, Lauri 
Mäenpää, Matti Hietala, Jussi-Pekka Kentala 

14022-ORC-J 21 (26) 

 

Copyright © Outotec Oyj 2014 

 
Fig. 33. Calculations (SimulationBar). Simulate and give iteration rounds for calculations. 

 
Fig. 34. Visualization (VisualizeStreamContentsBar). Select or unselect visualization mode and 
select the stream property that is visualized. The user can also change measurement units, open the 
Stream Table Editor, visualize stream connections, add a header and copy the flowsheet picture to 
the clipboard using this toolbar. 

 
Fig. 35. Drawing tool (DrawingToolsBar). With this toolbar the user can add shapes like an ellipse, 
rectangle, rounded rectangle, pie and chord. It is also possible to add a textbox. 

 
Fig. 36. Height and Width (SizeBar). With this toolbar the user can make the size of the selected 
units equal. 

 
Fig. 37. Align (AlignBar). With this toolbar the user can align selected units in many ways, thus 
making it easier to draw professional-looking flowsheets. 

 
Fig. 38. Layers (LayersBar). With this toolbar the user can edit pages and layers (Fig. 27) or change 
the position of overlapping units. 

 
Fig. 39. Rotate and Flip (RotateAndFlipBar). With this toolbar the user can rotate or flip units. 

 
Fig. 40. Status bar. With the status bar the user can zoom the flowsheet and check and uncheck the 
Persist Tool and Snap to Grid options. The Persist Tool remembers the last used drawing tool so 
that the user does not have to select the same tool again separately. The Snap to Grid option aligns 
the streams and units according to the grid on the flowsheet, thus making it easier to draw 
professional-looking flowsheets. 

 
Fig. 41. FileBar. The user can start a new, open an old, save the current process and save a backup 
of the current process using this toolbar.  

 
Fig. 42. TableBar. The user can insert a table using this toolbar (see also section 40.1.4). 
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40.3.2. Docking bars 
 

 
Fig. 43. Log viewer. This docking bar shows the user possible warnings and errors found during the 
simulation. 

 
Fig. 44. Process Tree. In this docking bar the user sees the flowsheet as a process tree. 
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Fig. 45. Properties - Unit Process and Drawings. 

 
Fig. 46. Properties - Stream Process and Drawings. 
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Fig. 47. Process Errors. 

 
Fig. 48. Unit Icons (Unit List Panel). With this docking bar the user can add Unit pictures to the 
flowsheet. The unit pictures are of generic type (see section 40.2.2). The user can switch the view, 
browse picture location, search by name, or change unit directory (top bar) or zoom icons (bottom 
bar). 

 
Fig. 49. Info and Links. The user can add for example instructions on how to use the flowsheet here. 
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Fig. 50. Stream Content Viewer. In this docking bar the user can see a tabulated summary of the 
stream properties. 

 
Fig. 51. Stream Visualization Settings. In this docking bar the user can change the settings of the 
Sankey diagram (thickness of the stream shows where most of the material goes). 
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40.4. Importing HSC Sim 7 models (HSC Sim 6 models are not supported) 
 
In HSC Sim 8 there is a built-in support for importing HSC Sim 7 models and then using 
them in Sim 8. However, there are some points and limitations that the user should take 
into consideration when importing Sim 7 models into Sim 8. If points listed here do not help 
please contact the developers. 
 
Major points: 
 

• Sim 8 calculations have dramatically stricter error checks than Sim 7. When the user 
imports an old model and tries to run it, often the calculation will notify of an error in 
the flowsheet. The user can locate the errors using the log viewer and then fix them 
manually. 

• There are some changes in the Sim 8 hydro variable list logic when compared to 
Sim 7. If the imported model variable list contains species not found in the database, 
the user needs to go through them case by case in the Sim 8 variable list editor. The 
user can add entries to the database, use a different database entry, or delete the 
species from the variable list to fix this (see Chapter 43, section 43.2.1). 

• Sim 7 solvent extraction hydro Excel Wizards are no longer supported in Sim 8. If 
the imported model contains them in Sim 8, the user will not be able to run the 
model successfully. 

• There is a completely new DLL unit operation system in Sim 8, which has been 
implemented for some Mineral Process unit operation models. Sim 8 has partial 
support for using old Sim 7 minpro Excel Wizard models and the user should be 
able to run calculations for the imported Sim 7 minpro Excel Wizards. However, the 
user cannot currently edit or make the Excel Wizards for the old minpro models. If 
users want to edit their old mineral process models, they should replace the old 
minpro Excel Wizards with the new DLL models. 

 
Minor points: 
 

• Sim 8 uses different Stream Tables than Sim 7. Because of this, users cannot edit 
Sim 7 Stream Tables in Sim 8 but they can make new ones using Sim 8 tools. 

• The visibility of the connected streams is forced on for input and output streams in 
Sim 8. If there are any such streams hidden in the imported Sim 7 model, they will 
appear in Sim 8. 

• A few drawing objects like a Bézier curve are not supported in the first version of 
Sim 8. 

• In some rare cases, Sim 8 does not recognize Sim 7 stream connections correctly. 
Information about this will be given in the import log. Afterwards the user should 
manually confirm the notified stream connections. 

• In Sim 7, the user had the possibility to encrypt some units. This function is no 
longer supported in Sim 8, which means those units will not be loaded during the 
import. 

• External workbook references work differently in Sim 7 and Sim 8. When you import 
a Sim 7 model, all external references are changed and will include “REF” at the 
beginning of the reference. 

• Sim 7 used automatically safe division for all division operations in the workbook. 
This meant that, for example, 0/0 did not give an error as the answer. Sim 8 adds 
the “safediv” function to division operations. 

• Sim 8 will change the sheet names of the workbook if the sheet contains illegal 
characters like “/”. 


